Critical Langflow Vulnerabilities Allow Unauthenticated Remote Code Execution
Two security flaws affect all versions from 1.0.0 through 1.12.8, with fix available in 1.13.0

Key Takeaways
- Two critical vulnerabilities affect Langflow versions 1.0.0 through 1.12.8.
- Unauthenticated remote attackers can bypass authentication and execute arbitrary code.
- No public exploits confirmed; vulnerabilities reported through IBM's disclosure program.
- Only fix is upgrading to Langflow version 1.13.0.
- All globally deployed Langflow instances running vulnerable versions are at risk.
Quick answers
- What happened?
- IBM reported two critical vulnerabilities in the Langflow open-source AI workflow platform that could allow unauthenticated remote attackers to bypass authentication and execute arbitrary code on affected servers. All versions from 1.0.0 through 1.12.8 are vulnerable; the only remediation is upgrading to version 1.13.0.
- Which products are affected?
- Langflow
- What should defenders do?
- Upgrade Langflow to version 1.13.0 immediately, which contains the security fixes for the reported vulnerabilities. All versions 1.0.0 through 1.12.8 remain vulnerable.
IBM disclosed two critical security flaws in Langflow, an open-source platform for building AI agents and workflows. The vulnerabilities affect every release from version 1.0.0 through 1.12.8, with the fixed release being 1.13.0. The flaws permit a remote attacker with no account to bypass authentication or run arbitrary code on the server. IBM noted that neither vulnerability appears in CISA's Known Exploited Vulnerabilities catalog at this time. The vulnerability reports were submitted through IBM's coordinated disclosure process. No public exploit code has been confirmed as of the advisory release. Organizations running outdated Langflow deployments are advised to upgrade immediately to version 1.13.0 to apply the security fixes.
Security Details
Two critical vulnerabilities in Langflow allow unauthenticated remote attackers to bypass authentication and execute arbitrary code. All versions from 1.0.0 through 1.12.8 are affected. The vulnerabilities were reported through IBM's vulnerability reporting program. No public exploit code has been confirmed. Details on specific CVE identifiers were not provided in the source.
Affected products
Langflow
Mitigation
Upgrade Langflow to version 1.13.0 immediately, which contains the security fixes for the reported vulnerabilities. All versions 1.0.0 through 1.12.8 remain vulnerable.
Sources
The Hacker News
Critical Langflow Flaws Could Let Unauthenticated Attackers Run Code on Servers
Nov 2, 2026 · 11:50
Original link
Related Security News

BTCPay Server Hot Wallet Thefts Prompt Urgent Update Advisory
The BTCPay Server maintainer has issued an urgent advisory warning that hackers are actively draining hot wallets from deployment instances running outdated versions of the open-source cryptocurrency payment processor. Users are strongly urged to update to the latest version to address the security flaws being exploited.

Malicious Instruction File Targets AI Coding Agent via Downloads Folder
A malicious instruction file discovered in a developer's Downloads folder attempted to manipulate an AI coding agent into installing a known-malicious npm package. The security firm Forever Security detected and stopped the attempt on a real customer machine before any code executed. The origin of how the file entered the Downloads folder remains unconfirmed.



