Four Critical Vulnerabilities Discovered in EPICS Base Software
CISA has issued an advisory (ICSA-26-300-01) disclosing four vulnerabilities in EPICS Base release 7.0.10 and prior. The flaws, tracked as CVE-2026-114595 through CVE-2026-114598, range in severity from CVSS 8.2 to 9.8 and involve integer overflow, improper handling of length parameters, and type confusion in network request processing. Successful exploitation could lead to denial-of-service, memory corruption, arbitrary code execution, or information disclosure. Updates to version 7.0.11 have been released via the epics-base and pvDataCPP GitHub repositories.